Resolved: アカウント誤停止および公開サイト非公開化の不具合について / Accidental account deactivation and impact on public sites

Incident Report for Studio

Resolved

(English follows)
2026年3月3日、一部の正常なユーザーアカウントが誤ってアカウント停止(退会)状態となり、そのユーザーが参加していた公開サイトが自動的に非公開化される不具合が発生しました。
現在は、アカウントの復旧および原因への対処を講じたうえで該当ユーザー様への連絡を完了しており、本インシデントは解消済みです。

■ 発生事象
・一部の正常なユーザーアカウントが誤って停止状態となる
・停止対象となったユーザーが参加していた公開サイトが自動的に非公開化される
・サイト管理者様による再公開操作を行っていない場合、サイトが閲覧できない状態となる

■ 発生日時(JST)
2026/3/3 18:00〜20:20 頃

■ 現在の状況
・誤って停止されたユーザーアカウントは、すべて復旧済みです。
・非公開となった公開サイトについては、自動で再公開されません。

本事象の影響を受けて非公開となったサイトの再公開を希望される場合は、以下の手順に従って管理画面より再度「公開」操作を行っていただく必要があります。
1. 対象プロジェクトを開き、公開パネルを表示します。
2. 公開パネル右上の[公開]ボタンをクリックします。
3. 公開が完了すると、ポップアップが表示されます。
4. 公開 URL をクリックし、サイトの表示を確認します。

詳しい手順は、以下のヘルプ記事もご参照ください。
サイトの公開方法: https://help.studio.design/ja/articles/9973234#h_0566d98f26

■ 発生原因
不正ユーザー対策として実施した一部アカウント制御処理において、内部ロジックの誤判定が発生し、正常なユーザーアカウントがスパムとして検出・停止対象となったことが原因です。
その結果、該当ユーザーが参加していた公開サイトが自動的に非公開化されました。

■ 再発防止策
アカウント判定ロジックおよび保護処理の設計・検証プロセスを見直し、本番環境に適用する前段階での検証をより厳密に行う体制を整備します。
また、類似の誤判定が発生した場合に、より早期に検知・復旧できるよう、監視およびアラートの自動化・高度化を進めてまいります。


このたびは、弊社の不備により、お客様のアカウントおよび公開サイトの閲覧に影響が生じましたことを、深くお詫び申し上げます。
今後とも Studio.Design を安心してご利用いただけるよう、再発防止に全力で取り組んでまいります。

---------------------------------------------------

On March 3, 2026, Studio.Design experienced a system issue that caused some legitimate user accounts to be mistakenly deactivated (treated as closed).
As a result, public sites those users belonged to were automatically set to private.
This incident has now been fully resolved, and corrective measures have been put in place.

■ Impact
- Some legitimate user accounts were accidentally deactivated.
- Public sites that those users belonged to were automatically set to private.
- Unless site owners manually republished their sites, those sites were not accessible to visitors.

■ Timeframe (JST)
March 3, 2026 (Tue) 6:00 pm to 8:20 pm

■ Current status
- All user accounts that were mistakenly deactivated have been fully restored.
- Sites that were set to private are not automatically republished.

If you wish your site to be public again, please republish it from your Studio.Design dashboard by following the steps below.
1. Open the affected project and open the Publish panel.
2. In the top-right of the Publish panel, click the “Publish” button.
3. When publishing is complete, a confirmation popup will appear.
4. Click the published URL and confirm that your site loads correctly.

For more details, please refer to this help article:
How to publish your site: https://help.studio.design/en/articles/2642690

■ Root cause
We recently introduced additional account control logic to help protect Studio.Design from abusive use.
Due to an error in this internal logic, some legitimate user accounts were incorrectly flagged as spam and deactivated.
As a side effect, public sites those users belonged to were automatically set to private.

■ Prevention and follow‑up
- Strengthening how we design, review, and test our account protection logic before it is deployed to the production environment.
- Enhancing our monitoring and alerting so that, if similar misclassifications occur in the future, we can detect and resolve them much earlier.

We sincerely apologize that this issue affected your account and public sites, and for the inconvenience it caused.
Posted Mar 04, 2026 - 00:15 JST
This incident affected: Hosted Websites, Editor, Dashboard, and Live Preview.